Tuesday, January 27, 2015

cPanel, Inc. has released EasyApache 3.28.2 with PHP versions 5.4.37 and 5.5.21.


cPanel, Inc. has released EasyApache 3.28.2 with PHP versions 5.4.37 and 5.5.21. This release addresses vulnerabilities related to CVE-2015-0231, CVE-2014-9427, and CVE-2015-0232 by fixing bug in the Core module, Exif extension, and CGI. We strongly encourage all PHP 5.4 users to upgrade to version 5.4.37 and all PHP 5.5 users to upgrade to version 5.5.21.

AFFECTED VERSIONS
All versions of PHP 5.4 through version 5.4.36
All versions of PHP 5.5 through version 5.5.20

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2015-0231 - MEDIUM

PHP 5.4.37
Fixed bug in the Core module related to CVE-2015-0231

PHP 5.5.21
Fixed bug in the Core module related to CVE-2015-0231


CVE-2014-9427 - HIGH

PHP 5.4.37
Fixed bug in CGI related to CVE-2014-9427

PHP 5.5.21
Fixed bug in CGI related to CVE-2014-9427


CVE-2015-0232 - MEDIUM

PHP 5.4.37
Fixed bug in Exif related to CVE-2015-0232

PHP 5.5.21
Fixed bug in Exif related to CVE-2015-0232


SOLUTION

cPanel, Inc. has released EasyApache 3.28.2 with an updated version of PHP 5.4.37 and PHP 5.5.21. Unless you have disabled EasyApache updates, EasyApache updates automatically. Run EasyApache to rebuild your profile with the latest version of PHP.

REFERENCES
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-0231
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-9427
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-0232
http://php.net/ChangeLog-5.php

Source : cPanel Inc.